NS-R not loading

Incident Report for Fearnley

Resolved

NS-R is available, you may need to re-login.
Posted May 06, 2026 - 12:12 UTC

Investigating

We are aware that NS-R is not loading and are investigating.
Posted May 06, 2026 - 11:28 UTC
This incident affected: NS Reporting App.