NS-R Unavailable

Incident Report for Fearnley

Resolved

The NS-R is now available.
Posted Nov 16, 2023 - 10:07 UTC

Identified

The NS-R is currently unavailable due to an outage with Microsoft.
Posted Nov 16, 2023 - 08:16 UTC
This incident affected: NS Reporting App.